OriginLab Corporation - Data Analysis and Graphing Software - 2D graphs, 3D graphs, Contour Plots, Statistical Charts, Data Exploration, Statistics, Curve Fitting, Signal Processing, and Peak Analysis     
 
Skip Navigation Links
All BooksExpand All Books
User GuideExpand User Guide

21 Customizing Origin


Customizing Default Settings

Setting Preferences with the Options Dialog Box

The multi-tabbed Options dialog box has controls for Origin global settings pertaining to numeric display, file and system paths, text fonts, Origin program opening and closing behaviors, etc.

To open the Options dialog box:

  • Choose Tools: Options (any Origin window is active)
  • If you are working with Excel in Origin choose Window: Origin Options (Excel workbook is active)
Controls For
Axis Tab
  • Max number of ticks for numeric and date/time scales
  • Distances from the tick labels to tick marks, axis titles
  • Display of log scales when using scientific notation
Excel Tab
  • Use of default plot assignments
  • Scan datasets for legend text
  • Opening Excel files by drag-and-drop
File Locations Tab
  • Set file paths to track last opened, last saved, last exported file
  • Set default path and file extension for importing different file types
  • Set file types in ASCII import dialogs.
Graph Tab
  • Dash lines definitions, line to symbol gap, user-defined symbols, etc.
  • 2D graph anti-aliasing.
  • Enable in-place editing of linked and embedded graphs
  • Speed mode reminder watermark
Miscellaneous Tab
  • Printing options
  • Default templates for ASCII import
  • Custom date/time formats
  • Footnote size ratio for report sheet
  • Use of dataset names in the Origin workspace
Numeric Format Tab
  • Controls for displaying scientific notation
  • Controls for displayed digits in data and report sheets
  • Radians, degrees or gradians
  • Separators for decimal places
Open/Close Tab
  • Default window closing behaviors
  • Project startup, backup and autosave options
Page Tab
  • Control of page size for exported graphs
Text Fonts Tab
  • Default fonts for text objects
  • WYSIWYG and in-place editing mode behaviors
  • Size and positioning of superscripts/subscripts
System Path Tab
  • Change the location of the users files, autosave and group folders
  • Locations of important Origin system folders

System Variables Dialog

System variables are internal Origin settings that allow for the fine-tuning of a wide range of Origin behaviors. Origin's Set Systems Variables dialog box (Tools: System Variables...) can be used to view and set system variable values. In the dialog, there is a link named System Variables List which opens a web page with a list of all system variables, the default value, and description.

To customize a particular system variable:

  1. Type the system variable name in the first column, without the @ symbol. For example, if you wish to make a global change to the Recalculate mode of analysis dialog boxes, type: DAM
  2. Click on the 2nd column to view the current value, and type in a new value. For example, with DAM, to set Recalculate to Auto, type the value: 1.
  3. Add optional comments in the third column and click OK to close dialog.

This modified value will be remembered and applied in every Origin session.

You can quickly read or set the value of a writable system variable in the Script Window (Window: Script Window) by typing @systemVariable= as, for example ...

@DAM=

... then pressing ENTER, but note that typing in the Script Window sets the variable value for the current session only.

3D OpenGL Settings Dialog

Origin uses OpenGL (Open Graphics Library) for rendering of 3D graphs. OpenGL provides enhanced performance including fast drawing, fast rotation and zoom, transparency, and lighting support.

For optimum performance, your card should support OpenGL version 3.0 or higher. To check your hardware's support for OpenGL, run Origin and choose Tools: 3D Open GL Settings.... Look under OpenGL Info for information on graphics hardware and the supported version of OpenGL.

If your graphics hardware is older, you may experience compatibility issues with things such as transparency settings and anti-aliasing. The controls under the Settings node in this dialog allow you do such things as disabling transparency. The dialog box also provides information on disabling OpenGL.

For more information on OpenGL in Origin, see the links under "Topics for Further Reading" at the end of this chapter.

Customizing Menus

Custom Menu Organizer

If you have scripts that are frequently run, you can add them to the menu for quick access. With the Custom Menu Organizer you can...

  • Create up to 3 main menus and corresponding sub-menus
  • Assign LabTalk scripts and X-Functions to a menu item
  • Restrict menu item access to specific window types
  • Hide unused built-in menu items, streamlining your Origin workspace

To open the Custom Menu Organizer, choose Tools: Custom Menu Organizer... from the main menu. Then press F1 or click the button Question mark.png in the upper-right hand corner of the dialog box for instructions.

Once you create and save a new menu configuration (.omc) file, you can then select that configuration from the Format: Menu fly-out menu. Multiple configuration files can be created, allowing you to easily switch from one configuration to another. A Default configuration is also available in the fly-out, to revert to default menu settings. Configuration files can also be shared with colleagues.

Displaying Bitmaps in Menus

You'll note that form some menu commands, a bitmap is displayed to the left of the menu entry. The bitmap indicates that there is an equivalent toolbar button.


On some systems such as VirtualPC or Terminal Servers, such bitmaps may cause a long delay when opening menus. To turn off the display of menu command bitmaps:

  1. Select Tools: Options to open the Options dialog box.
  2. Select the Miscellaneous tab, clear Display Bitmaps in Menus, and click OK.


Customizing Toolbars and Buttons

In addition to the standard Windows OS toolbar customizations, Origin provides some clever and easy-to-use tools for creating, programming and distributing custom toolbar buttons. If you or your staff are performing complex but repetitive Origin routines, you'll want to explore creating and sharing custom toolbars.

Displaying, Hiding or Moving Toolbar buttons

  • Click the small down arrow at the end of any toolbar and select the Add or Remove Buttons context menu. Then select desired sub menu and check/uncheck to show/hide buttons. A Reset option is also available.
  • Press ALT key and drag a button to any new toolbar location.
  • Press ALT key and drag a button to blank Origin workspace to create a new toolbar.
  • Press ALT key and drag a button to any window till X shows, then release to delete the toolbar.

Customizing Toolbar Button Appearance

Use controls on the Options tab (View:Toolbars) to:

  • Show toolbar screen tips and shortcut keys on hover
  • Increase toolbar and toolbar button size
  • Toggle between "flat" or 3D toolbar buttons

Displaying or Hiding a Toolbar

  • Double click the left/top end of any docked toolbar to undock. Double-click on title of floating toolbar to dock.
  • In floating mode, click X button to hide the toolbar. Drag it to any new location to reposition. Drag it to edge of the Origin workspace to dock.
  • In docked mode, drag the left/top end of a toolbar to reposition.
  • To show/hide multiple toolbars together, choose View: Toolbars... from the main menu. Use the check boxes on Toolbars tab to show/hide toolbars. Click the New button to add a new toolbar, then drag buttons from the Button Groups tab to add buttons on the new toolbar.
  • Use the Reset, Reset All buttons to reset toolbars.

Creating New Toolbars with New Bitmap Images

Origin supports creating new toolbar buttons with Labtalk script, both built-in or user-defined script to run when click it. Choose View: Toolbars... and create new button group on Button Group tab.

  • Origin ships with three button groups starting with User Defined... with a bunch of bitmap images.
  • Click any button and click Settings... button to link .ogs (Script) file section with the button.
  • Drag the button to Origin workspace to create toolbar button.
  • If you are feeling really creative, Origin allows you to define a new button group that uses your own 16 color, 16 x 16 pixel bitmaps.
  • Export the button group as an .OPX file and share it with others. The person who gets the OPX can drag and drop the OPX file onto Origin workspace to install the toolbar.
Note: To learn more about creating and exporting user-defined toolbars, see:

Help: Origin: Origin Help > Customization and Automation > Customizing Toolbars

Add a Custom Button to the Window Title Bar

Origin supports adding a system button to the left of the minimize button on the window title bar. A custom LabTalk script can then be associated with this button.

Note: Please view the -tbb option of the LabTalk Page command in the Programming help file:

Help: Programming: LabTalk > Language Reference > Command Reference > Alphabetical Listing of Commands > Page

Customizing the Status Bar

Origin uses the Status bar at the bottom of the Origin workspace to report software hints, statistics and other useful information depending upon current action, selection, window, etc.

  • Right-click on Status Bar to customize the display.
  • Press ALT and drag items along the Status Bar to reorder.

Customizing the Origin Workspace

Origin also supports customizing dockable windows such as the Project Explorer, Quick Help and Messages Log windows.

  • Right click on the window title bar to specify dock, hide, auto hide, and other settings.
  • When auto-hide is unchecked, double click to float the window.
  • Drag the window title to move or dock to a new location.
  • Arrange dockable windows as multiple tabs along the edge of the workspace to save screen space.
  • Choose View: Toolbars... from main menu. On the Toolbar tab:
    • The Reinitialize button resets menu, toolbar and dockable windows to default settings.
    • The Export button exports the current menu, toolbar and dockable window settings to an .OPX file. Drag and drop the OPX file onto another Origin installation to configure the workspace to match your customized settings.

Templates and Themes

The hierarchy of Origin objects such as graph pages, combined with extensive object properties, lends itself to the creation of custom settings for repeat use. You can save your custom settings either as templates or themes, described briefly in the following sections.

Note: For detailed information please refer to Origin Help file, see:

Help: Origin: Origin Help > Origin Basics > Origin Template Files (OTW, OTP, OTM)

Templates

The Origin template concept applies to graphs, workbooks, matrix books, and Analysis Templates™. Templates allow you to choose a set of properties or operations and save those for repeat use.

For instance, Origin ships with over 100 built-in graph templates that are used to create Origin’s many science and engineering graph types. Using one of these as a starting point, you can create your own graph, adding more layers, setting scale or dimensional relationships between layers, modifying data plot properties, etc., and then save your customizations as a user-defined graph template (.otp) file by clicking File: Save Template as....

You cannot overwrite built-in templates (graph or otherwise). If you customize a template, then choose Save Template as… and attempt to overwrite the built-in template (by saving the file with the same name), the custom template will be saved to your User Files Folder (UFF). This UFF copy then takes the place of the built-in template and this template will be used when clicking the corresponding menu command or toolbar button. To reconnect a built-in template with these menu commands or toolbar buttons, you will need to delete (or remove) the customized template from your UFF.

An important subset of graph templates are what are called “cloneable” templates. These templates display a “sheep” icon next to the template name or preview image. For more information, see the section on cloneable templates in Graph Template Basics in your Origin Help file.


Template Library 2016 GSB.png

The template concept extends to workbooks and matrices, as well. You can save workbook or matrix book settings, such as the number of columns and sheets, column plot designations, fonts, colors, display formats, custom header rows, scripts associated with the sheet, or dimension and coordinate settings, to .otw (workbook template) or .otm (matrix template) files.

Another important Origin template concept is the Analysis Template™. Save data operations -- even complex operations such as curve fitting with resulting custom report sheets -- to an analysis template (.ogw or .opj) for repeat analysis with similar data. Analysis templates are explained in more detail in the Batch Analysis section of How to Handle Repetitive Tasks chapter of this guide.

Themes

An Origin Theme is a file containing a set of object properties or dialog settings. Thus for example, the customized settings of a graph window can be saved as a Theme, or the customized settings in an analysis dialog can be saved as a Theme.

A Graph Theme could be as simple as an axis tick mark direction setting, or as extensive as a collection of multiple graph object properties.

Themes allow you to quickly apply a new set of properties to an object, such as a graph. For example, you might apply a black-and-white Theme to a color graph in order to prepare it for publication. Or you might take the object properties of one graph and apply them to all the other graphs in the same project.

Right click on plot, layer, object, etc. in graph or right click with nothing selected in graph and choose Copy Format context menu to copy format. Depending where you right click, the corresponding selection's format can be copied. Then right-click on corresponding selection or right click in target graph and click Paste Format to apply the copied settings to the target selection or graph. You can also choose Edit: Paste Format... to paste the Format to multiple target graphs.



Copy and paste format.png

The Theme Organizer dialog box is available from the Tools menu. Use this dialog to organize graph, worksheet, and dialog themes.

With this dialog you can apply a graph theme to multiple graphs to have consistent look. To combine multiple graph themes in the Theme Organizer dialog, hold down Ctrl while selecting the Themes, and then right-click to access the Combine context menu. The context menu in the tool provides an option to edit a Theme, allowing the user to add/delete properties to an existing theme. Set a theme as system theme will apply it to future newly created graphs automatically if the graph template allows system theme to override.

Graph theme organizer.png

The Theme concept extends to dialog box settings, as well. For instance, you can choose a particular suite of settings in the Linear Fit dialog box (Analysis:Fitting:Linear Fitting), and then save those settings to disk as a named Theme file. You can save multiple Theme files for a given dialog box and then recall them from the dialog, as needed. Saving multiple Themes for a dialog box allows you to customize your analysis routines from different experiments, when each requires using a specific (and unique) group of settings.

Save my theme.png


Dialog themes are explained in more detail in the How to Handle Repetitive Tasks chapter of this guide.

Topics for Further Reading


 

© OriginLab Corporation. All rights reserved.